Webservice Gateway (WSG) Service in Stopped State

SRM: Webservice Gateway (WSG) Service Failed to Start After Fresh RHEL_Binary Deployment

Summary: After a fresh RHEL_Binary deployment, The SRM Webservice Gateway (WSG) service fails to start in SRM VM's.

Detailed Article
Symptoms:

WSG service unable to start/restart in ABE environment.
Services stopped right after fresh installation.

[xxxx bin]# ./manage-modules.sh service status all

 * Checking 'topology-mapping-service Default'...                    [ running ]

 * Checking 'webservice-gateway Default'...                          [ stopped ]

 * Checking 'mysql Default'...                                       [ running ]

 * Checking 'backend apg1'...                                        [ running ]

 * Checking 'backend apg2'...                                        [ running ]

 * Checking 'backend apg3'...                                        [ running ]

 * Checking 'backend apg4'...                                        [ running ]

 * Checking 'collector-manager emc-watch4net-health'...              [ running ]

 * Checking 'event-processing-manager emc-watch4net-health'...       [ running ]

 * Checking 'task-scheduler Default'...                              [ running ]

Error logs (gateway-0-0.log) showed:

SEVERE -- HttpServer::start(): an error occurred starting the server

java.net.BindException: Address already in use

SEVERE   -- [2025-12-21 19:13:40 EST] -- Bootstrap::main(): An error occured starting the Webservice Gateway !

com.watch4net.apg.webservice.server.ServerException: an error occured starting the server

Cause:
The error was traced to a port conflict. The WSG service attempted to bind to port 48443, but another process was already using it. This resulted in the java.net.BindException: Address already in use error, preventing the service from starting.

Resolution Steps:

1. Identify the process occupying the port

Run the following command to check which PID is bound to port 48443:

[xxxx logs]# sudo lsof -i :48443

COMMAND   PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME

java    19694  apg   49u  IPv6  52334      0t0  TCP *:48443 (LISTEN)

java    19694  apg   67u  IPv6 645041      0t0  TCP <ABE_FQDN>:48443-><PBE_FQDN>:36744 (ESTABLISHED)

java    19694  apg   69u  IPv6 645658      0t0  TCP <ABE_FQDN>:48443-><PBE_FQDN>:36770 (ESTABLISHED)

java    19694  apg   72u  IPv6 645880      0t0  TCP <ABE_FQDN>:48443-><PBE_FQDN>:36788 (ESTABLISHED)

java    19694  apg   74u  IPv6 647343      0t0  TCP <ABE_FQDN>:48443-><PBE_FQDN>:55076 (ESTABLISHED)

 

2. Terminate the conflicting process

Kill the identified PID to free up the port:

kill -9 <PID>

3. Restart the services

 ./manage-modules.sh service restart all

Once the port was released, restarting the services brought them up successfully

 

Result: After restart all Services are up and running.

Affected Products

SRM